Flash Builder 4 코드힌트가 뜨지 않을때

이것때문에 미치는줄 알았습니다. 보통 Ctrl + Space키를 누르면 코드힌트가 뜨게되는데요.. 언제부턴가 이게 잘 안뜨는 겁니다. 정확히 말하자면 코드힌트가 만들어놓은 컴포넌트를 패키지와 함께 인식을 못하는듯한 증상이였죠.. 뭐 수동으로 xmlns 타이핑하고 사용하면 문제는 없습니다.

처음엔 이클립스설정이 좀 꼬였나부다 했었는데 증상이 자주 되다보니 너무답답해서 하루동안 삽질좀 해봤죠. 문제는 좀 황당한곳에 있었습니다. 주로 MXML파일에서 asDoc 문서 생성을 위해 사용한 주석 내용 때문에 코드힌트가 확인하지 못하는 문제였습니다. 어쩐지 MXML파일만 코드힌트가 안나오드라고요..에이 C

저는 보통파일 만들때 다음과 같이 주석을 박아놓고 시작합니다(Preferences>Flash Builder>File Templates 기능). 많이들 사용하시죠..

이렇게 설정해 놓으면 파일을 새로 만들때마다 같은 포맷으로 만들 수 있습니다. 저는 다음과 같이 만들어 집니다.

<?xml version="1.0" encoding="utf-8"?>
<!---  
/** 
* 하하하
* @Project : Vulcan Project
* @Author : Park Dong-il (
pdi1066@naver.com)
* @Date : May 4, 2010
*/
-->

<s:Group
 xmlns:fx="http://ns.adobe.com/mxml/2009"
 xmlns:s="library://ns.adobe.com/flex/spark"
 xmlns:mx="library://ns.adobe.com/flex/mx"
 width="400" height="300"
 >


그런데 이렇게 만든 MXML 파일이 코드힌트가 적용이 안되더라 이겁니다. xml 정의 구문 바로 밑에서 "-"세개짜리 주석을 시작하면 AS파일에서 클래스 주석 다는것과 같은 기능으로 자동으로 도움말 문서가 작성되게 되는데 요놈때문에 코드 힌트가 나오질 않았습니다. 사실은 보통의 경우 정상작동하는데 제 경우에는 좀 특이한 상황이였습니다. 다음과 같이 사용하면 정상작동합니다. 

 <?xml version="1.0" encoding="utf-8"?>
<!---  
/** 
* 하하하
* @Project : Vulcan Project
* @Author : Park Dong-il (
pdi1066@naver.com)
* @Date : May 4, 2010
*
-->

<s:Group
 xmlns:fx="http://ns.adobe.com/mxml/2009"
 xmlns:s="library://ns.adobe.com/flex/spark"
 xmlns:mx="library://ns.adobe.com/flex/mx"
 width="400" height="300"
 >

차이점을 발견 하셨나요?.. 무슨 틀린그림찾기도 아니고... 주석문에서 마지막 "/" 부분을 삭제 했습니다.


이렇게 잘나오는 것을...정말 생각지도 못한 곳에서 문제의 원인이 있을때 삽질 제대로 하게 되지요..욕도 절로 나오게 되구요..마지막엔 썩소를 날리면서 피식하게 되지요..ㅎㅎ 사소한 버그로 넘어갈수도 있지만 이미 많은 시간을 빼았겨버린 후라서 맘에는 안드는 군요. Flash Builder 신뢰성에 살짝 스크라치가 생기네요..

 

 

저작자 표시 비영리 변경 금지
신고
트랙백 ( 0 )개 , 댓글 ( 2 ) 개가 달렸습니다.

Commentary

댓글을 달아 주세요.

  1. Favicon of http://webnoon.net BlogIcon 웹눈 2010.05.04 09:04 신고  댓글주소  수정/삭제  댓글쓰기

    오..저도 코드힌트가 안나와서 스트레스받던 중이였는데 한번 적용해봐야겠습니다. 감사합니다 ㅎㅎ

Add a Comment

comment에 대한 답변글은 해당 글상자에 있는 "R"(reply)버튼을 클릭하여 작성해 주시기 바랍니다.

티스토리 툴바